Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 18, 2026 - 22:00 CST
Scheduled
As part of our ongoing commitment to providing a secure and reliable experience, WellSky will be performing 4 hours scheduled maintenance to upgrade the Citrix hosting infrastructure that supports your WellSky CareTend Production environment. This will occur starting on Wednesday, February 18th, 2026 from 10:00 PM to Thursday, February 19th 2:00 AM (Central Time). During this time, the Solution will be unavailable. **This is phase two of a two phase upgrade** This work will occur during WellSky’s regularly scheduled monthly maintenance window. The following services may not be available during this window: CareTend, CareTend BI, CareTend Employee Login Manager. If you have any questions or concerns, please don’t hesitate to reach out to the WellSky Support team.
We thank you for your patience as we improve the system.
Posted Feb 04, 2026 - 11:22 CST
This scheduled maintenance affected: CareTend and CareTend Business Intelligence (BI).