Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 14, 2025 - 22:00 CDT
Update
WellSky will perform a scheduled maintenance on Sunday, September 21st from 10:00 PM CT to September 22nd at 5:00 AM CT. Please Note, this is a reschedule of the maintenance event originally scheduled for 09/14.
During this maintenance window, the below solutions may be temporarily unavailable: CareTend CareTend BI eRx Hub Drug Information Service (DIS) CareTend Data Extract (Snowflake)
We thank you for your patience as we improve the system.
Posted Sep 11, 2025 - 14:46 CDT
Scheduled
WellSky will perform a scheduled maintenance on Sunday, September 14th from 10:00 PM CT to September 15th at 5:00 AM CT. During this maintenance window, the below solutions may be temporarily unavailable: CareTend CareTend BI eRx Hub Drug Information Service (DIS) CareTend Data Extract (Snowflake)
We thank you for your patience as we improve the system.
Posted Sep 10, 2025 - 13:08 CDT
This scheduled maintenance affected: CareTend, CareTend Business Intelligence (BI), and CPR+.