Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 13, 2025 - 22:00 CST
Scheduled
CoverMyMeds will perform a scheduled maintenance on Saturday, December 13, 2025, at 10:00 PM CST, with completion expected by Sunday, December 14, 2025, at 7:00 AM CT. During this time, the CoverMyMeds web portal will be unavailable. However, users can continue to initiate prior authorization requests through all other integrations during the system maintenance period.
We thank you for your patience as we improve the system.
Posted Dec 10, 2025 - 09:46 CST
This scheduled maintenance affected: CareTend and CPR+.