Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 04, 2026 - 23:00 CDT
Scheduled
WellSky has identified an issue requiring immediate maintenance. We will perform this maintenance on Tuesday, August 4th, 2026, from 11:00 PM to 11:30 PM (Central Time). During this time, the solution will be unavailable.
We apologize for the inconvenience as we work to provide a better experience for our clients.
Posted Aug 04, 2026 - 11:13 CDT
This scheduled maintenance affected: Bonafide, powered by WellSky.